
RELEASE NOTES

Release Notes for Modo 11.0v1

Release Date
20 April 2017

System Requirements

Officially Supported Operating Systems

• Mac OS X 10.10.x, 10.11.x, and 10.12.x (64-bit only)

• Windows 7, Windows 8, and Windows 10 (64-bit only)

• Linux 64-bit operating system (CentOS/RHEL 7+)

MinimumHardware Requirements

• Intel processor(s), Core i3 or higher

• 1 GB available hard disk space (for Modo installation).

• 6 GB available hard disk space (for full content).

• At least 4 GB RAM

• Display with 1920 x 1080 pixel resolution

• Internet connection for product activation and online videos access

• The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of
graphics memory and drivers that support OpenGL 3.2 or higher.
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Recommended SystemRequirements

NOTE: This information is our best recommendation for the average user. Requirements
vary by usage, and individual users may have different requirements from those listed here.

• 2.5+ GHz quad-core processor

• 250+ GB disk space available for caching and temporary files, SSD is preferable

• 16 GB RAM with additional virtual memory*

• Display with 1920 x 1080 pixel resolution

• An NVIDIA or AMD graphics card with the latest drivers

• 2+ GB of graphics memory

• OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.

TestedWorkstation Hardware

The configurations listed below are those that The Foundry have tested with Modo 11.0v1. Due to the
constantly changing nature and wide variety of computer hardware available in the market, The
Foundry is unable to officially certify hardware. The list below can be used as a recommendation and
does not guarantee that it meets your particular needs.

Please download and install the latest graphics driver from the NVIDIA or AMD websites. Make sure
that you are using 8.982.8.1 drivers or higher for AMD cards.

If you encounter any issues, please visit the Support Portal at supportportal.thefoundry.co.uk.

Tested Workstation Hardware

Apple • MacPro4, 1

• MacPro5, 1

• iMac13, 2

• MacBookPro10, 1

Dell • Dell T1700

• Dell T3610

• Dell T3620

Release Notes for Modo 11.0v1 |
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Tested Workstation Hardware

• Dell T5810

• Dell T7610

• Dell T7910

• Dell Precision Rack 7910

• Dell Precision 5510

• Dell Precision 5520

• Dell Precision 7710

• Dell Precision 7720

• Dell M2800

• Dell M6800

HP • HP Z440

• HP Z600

Tested GPU Hardware

AMD Prosumer Graphics Cards • Radeon™ HD 1900 XT

• Radeon™ HD 2400 XT

• Radeon™ HD 2600 Pro

• Radeon™ HD 3870

AMD Enterprise Graphics Cards • FirePro™ W4170

• FirePro™ W5000

• FirePro™ W8000

• FirePro™ W2100

• FirePro™ W5100

• FirePro™ W4100

• FirePro™ W7100

• FirePro™ W8100

• FirePro™ W9100

• Radeon Pro WX7100

• Radeon Pro WX5100

Release Notes for Modo 11.0v1 |
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Tested GPU Hardware

• Radeon Pro WX4100

NVIDIA Prosumer Graphics Cards • Geforce GTX 680

• Geforce GTX Titan

• Geforce GT 650M

NVIDIA Enterprise Graphics Cards • Quadro® K6000

• Quadro® K5000

• Quadro® K4000

• Quadro® K2000

• Quadro® K600

• Quadro® K5200

• Quadro® K4200

• Quadro® K2200

• Quadro® K1200

• Quadro® K620

• Quadro® M5000

• Quadro® M4000

NVIDIA Quadro Graphics Cards: • P400

• P600

• P1000

• P4000

• P5000

New Features

Games

Game Export Improvements

The Game Asset Exporter has been redesigned to make it more useful and easier to manage.

Release Notes for Modo 11.0v1 | New Features
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Progressive Baking Accessibility

Progressive Baking is now available from the menu bar, by clicking Render > Open Progressive
Baking.

Unreal Material Importer Workflow Improvements

Some improvements have been made to the material importer workflow for Unreal, you can now:

• Import materials to any folder in Unreal Engine's Content Browser.

• Import textures into the texture sub-path, which can be specified in Modo's Game Asset Exporter.

• Import and update only selected materials in the Content Browser.

• Import and update only the materials that are used by selected meshes in the Content Browser.

• Assign materials to imported meshes, instead of instances in the scene.

• Use both theModo Material button and Unreal Engine 4's Import button to import materials.

Modeling

Auto Retopo Improvements

The following new options have been added to the Automatic Retopology tool:

• Shortest EdgePoly Scaling option

• CurvaturePoly Scaling option

• Adaptive Poly Countmode

• New Mesh option

Auto-activating Ghosting and Edit BaseMesh Command

Accessing the base mesh in procedural modeling has been simplified. When any base mesh is
selected, ghost mode is now automatically enabled. Secondly, the Edit Base Mesh command has
been added in the mesh options. This command directly sets up the editable base mesh mode for the
selected item.

Release Notes for Modo 11.0v1 | New Features
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Implicit Mesh Operation Selection

Items that are related to the sameMesh Operations list are now implicitly selected, so all their
properties are visible at the same time.

MeshFusionWorkflow Enhancements

The following improvements have been made to the MeshFusion workflow:

• In-place Compound Trim creation and editing - a new workflow has been added for automating
the creation and editing of Compound Trims.

• Cut, Copy, Paste, and Split tools - new commands have been added for cutting, copying, pasting,
and splitting elements of a Fusion Item.

• Optimization Control - you can now optimize MeshFusion performance by either caching Boolean
operation, or by caching meshes.

Remove-Delete Keyboard Shortcuts

The keyboard shortcuts for deleting and removing components have been changed. The Delete and
Backspace keys delete components, while Shift+Backspace removes polygons. 

Sculpt Brush Preview

When a brush-based tool is activated, a circle is now drawn under the mouse when you hover over a
surface, to make painting and sculpting easier.

Select by Previous Operation

This new mesh operation allows you to select previously created elements in theMesh Operations
list.

Out of the Box Experience

Grid Display

A new panel has been added to specify Work Plane and grid display. You can click Work Plane > Grid
and Work Plane settings to open the panel.

Release Notes for Modo 11.0v1 | New Features
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Installation Streamlining

The following improvements have been made to the installation process:

• License dialog - the License dialog has been updated.

• Application name - Modo now installs using a proper Foundry naming convention.

• Start after install - the Windows installer now includes an option to start Modo after completing
the installation process.

• Modo content - Modo now includes a core set of content. Basic sets of assemblies, aliases,
brushes, colors, matcaps, basic and sculpting meshes, profiles, paint and sculpt tools, and image
inks are provided. The Preset Browsers point to these core presets by default, where applicable,
while still providing access to external content.

• Start-up messages - the various start-up messages have been consolidated into one dialog.

• New version warning - when a new Modo version is available, a notification is displayed,
prompting you to download it. Clicking Yes in the dialog opens the
www.foundry.com/products/modo/download page.

Introduction Screen

The new introduction screen allows you to quickly open and create projects, and access learning
materials.

Motion Blur for Procedural Meshes

Procedural meshes now support motion blur. This allows procedural geometry that has been
generated by mesh operations, to appear blurred as the polygonal elements move through the
frame.

Preview Render Region Toolbar

A toolbar has been added to the Render tab to activate and set a render region in Preview, as well as
change the render camera.

SafeMode

To aid customer support in debugging issues, you can now run Modo without loading any kits, plug-
ins, or custom configurations.

Release Notes for Modo 11.0v1 | New Features
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Tool HUD

The Tool HUD, a context-sensitive form containing recently used tools, is available in the 3D viewport
for every layout. You can toggle its visibility by pressing Ctrl/Cmd+Tab.

VDBVoxel Improvements

The following improvements have been made to the VDBVoxel item:

• Transform options - the VDBVoxel item now has Transform options in the Properties panel.

• Velocity Scale - velocity data can now be loaded if a voxel is created from particles that have
velocity information. Velocity Scale is used for scaling velocity data, by default it is set to 0, so as to
match the results in previous Modo versions. The value of velocity impacts generated voxels and the
generated mesh.

• Motion Blur - a scale value for motion blur, applicable to voxels created from particles that have
velocity information.

Performance and Efficiency

Backdrop Item Visibility

A Show in Perspective checkbox has been added to the Backdrop item properties, which enables
and disables the visibility of Backdrop items in the Perspective view.

Curve Particle Generator Improvements

The Curve Particle Generator's alignment has been improved and new End of Curve behaviors have
been added.

ItemDraw Cache

To speed up the display of items, several improvements to internal item drawing have been made,
especially in the cases of locators and animation. The animation display is now cached for every
frame for faster playback.

Release Notes for Modo 11.0v1 | New Features
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Faster Viewport Switching with Gradient

The speed of switching from the Default to the Advanced viewport has been improved.

Fur in the Advanced Viewport

With the fur material, fur can now be displayed as segmented lines in the Advanced viewport.

GL Drawing Performance

The speed of drawing instance items, replica surfaces, and replica bounding boxes has been
improved.

Item List Improvements

The following improvements have been made to the Item List:

• Fast item hiding - you can now quickly hide and reveal items using the Alt+click and Shift+Alt+click
keyboard shortcuts.

• Select button - the Select button at the top of the Item List now allows you to select items using a
specific text pattern.

• Render camera icon - the render icon is displayed next to the render camera, and its name is bold.
You can now also set the render camera by right-clicking the camera in the Item List.

OpenSubdiv Drawing Package

The OSD drawing override now draws Pixar subdivision surfaces using OpenSubdiv 3.0 instead of
native Catmull-Clark and Subdivision polygon mesh drawing. This improves the drawing speed for
high subdivision levels.

Schematic Improvements

The following improvements have been made to the Schematic viewport:

• Node snapping - nodes are snapped into position when added to the Schematic.

• Instancing links - instances are highlighted in pink when you select their source item.

• Select Inputs - you can now select a node and all its incoming nodes by right-clicking the node,
then in the context-menu, clicking Select Inputs.

Release Notes for Modo 11.0v1 | New Features
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Selection Sets

• Selection set groups - you can now organize items using a specific selection set into a selection set
group.

• Selection set UI - selection sets have been made more accessible by adding a button to the modes
toolbar, which opens the Selection Sets panel.

Spline and Bezier Deformer Improvements

Modo 11.0 adds an improved method for computing the setup of deformed transformation, to avoid
twisting problems. The following properties have also been added to the Spline and Bezier Effector's
properties:

• Draw Setup

• Align To Spline

• Anti-Twist Threshold

• Use Twist

• Use Scale

• Orbit Twist

Transform and Duplicate

You can now transform and duplicate components at the same time, holding Ctrl/Cmd+Shift when
using the Transform tools.

Rendering

Irradiance Caching Improvements

The following enhancements have been made to irradiance caching:

• Anisotropic irradiance values - cached irradiance values previously had circular regions of
influence based on their distance to the closest nearby surface. This meant that IC values tended to
be densely packed near inside edges such as between a wall and a ceiling. Now they can have
elliptical regions of influence, allowing them to be spaced further apart in the direction parallel to
an inside edge, potentially saving render time and memory.

• Store Direct Light option - this option is now enabled by default. It includes illumination from
direct light sources in addition to indirect illumination in the secondary irradiance cache values,

Release Notes for Modo 11.0v1 | New Features
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saving time whenever a first bounce indirect ray hits a surface that already has cached secondary
values.

MaximumRadiance

TheMaximum Radiance render setting has been changed into a unitless floating point number and
it acts as a multiplier for the most highly exposed render output in the scene.

Mesh Light Improvements

The following enhancements have been made to mesh lights:

• Caustics - mesh lights and cylinder lights can now generate caustics like other direct light types.
Direct caustics need to be enabled in the Render Global Illumination settings, and caustics only
show in final renders, where photon tracing is calculated.

• Use Prototype Transform - this new option allows you to position a mesh light item's light by
positioning the prototype mesh item. This option is enabled by default, but scenes created in
previous versions still load with this option disabled.

Occlusion Baking Improvements

Occlusion rays fired from the base of the source surface no longer hit the back side of polygons by
default. In order for occlusion rays to hit the back side of surfaces, their materials need to be double-
sided.

Render Output Masking

Render outputs now support group masks and layer masks in the Shader Tree. 

Simplification of Render Settings

The render Properties tabs have been updated to use form proficiency levels to hide many of the
more advanced controls by default and allow focus on the most relevant options. In addition, the
render settings preset loader and camera picker are available on all three tabs.

Release Notes for Modo 11.0v1 | New Features
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Feature Enhancements
• Deformers: Most of the hidden channels for the Spline and Bezier Deformers have been moved into
the Properties panel.

• Windows only: Support for SolidWorks 2017 has been added.

• File Output: Games Export - Texture export paths have been fixed so they are no longer considered
absolute paths if prefixed by a forward slash.

• Network Rendering: We now pass frame buffers back from slaves for per-frame rendering.

• Render layout: The Material-level Importance control now also affects indirect (GI) and direct light
samples, which allows you to use it to control the overall quality of a specific material.

• Render layout: An error message has been added for the render.dpi being disabled when not using
physical resolution units.

• Sculpt: A sculpt.constraint tool has been added to the Preset and Sculpt toolbar. In addition, the
Sculpt toolbar now has added labels on the dividers to allow collapsing of tools and settings.

• UI: An Add Loop tool has been added to the contextual pop-up menus and to the Tool HUD.

• UI: A progress monitor has been added to UV Atlas creation.

• BUG ID 37933 - Replicators: A Render Multiplier Radius option has been added to control the size
of the multiplication area.

• BUG ID 39414 - UI: Dynamics Soft Body tooltips have been updated.

• BUG ID 44623 - UI: For easy access, the Constraint Modifier and Procedural Shatter Dynamics
items have been added to the Setup layout Toolbox.

• BUG ID 46919 - Model layout: The Use Connectivity algorithm for the Soft Selection Falloff has
been improved.

• BUG ID 48433 - Preview: Un-premultiply support for saving Preview images has been added.

• BUG ID 49144 - UI: An option to auto-disable a backdrop item's visibility in non-orthogonal views
has been added.

• BUG ID 50490 - Dynamics: The Bezier Falloff and Spline Falloff dropdown menus now use user
names rather than internal names.

• BUG ID 50493 - Dynamics: Dynamic Item properties for the Sleep >Wake On > Force option is now
capitalized.

• BUG ID 52554 - Documentation: The Mirror topic has been updated to include more information
about setting theMirror Generator Mode to different Axis options.

• BUG ID - 52743 UI: Tooltips have been added to Particle Expression and other Particle modifiers.

• BUG ID 53234 - File Output: A confirmation dialog has been added to allow you to overwrite
previously exported .exr files using the same file name.

• BUG ID 53769 - Dynamics: The legacy option Particle Emit Group was removed from the UI.

Release Notes for Modo 11.0v1 | Feature Enhancements
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• BUG ID 53841 - UI: A typo was corrected in Preferences > Defaults > Switcher Bar for Initially
Collapsed.

• BUG ID 54188 - Item List: A warning dialog has been added to alert you that you are about to delete
filtered texture locators.

• BUG ID 54236 - Dynamics: Margins for Dynamic Replicators are now locked to the value at the
beginning of a simulation. Rigid Bodies that share a common collision shape can't have different
margins. This prevents Modo from crashing when changing the margin value while simulating.

• BUG ID 54520 - Model layout: The auto-activate in tool presets has been enabled for the following
tools: Bevel (vert,edge,poly), Extrude (vert,edge,poly), Slice (edge,poly), uv.peeler, uv.relax, uv.create,
poly.sweep, poly.loopslice, Dicer, and Julienne.

• BUG ID 54897 - Particles: We have removed theWake on Particle option from the Dynamic Item
properties.

Bug Fixes
• BUG ID Render layout: Primary rays were clamped when changing ray clamping values (maximum
radiance).

• BUG ID Render layout:  Occlusion rays hit the backside of single-sided polygons.

• BUG ID 15714 - Model layout: Running the vert.join command created corrupted UVs.

• BUG ID 24638 - UV: Switching to the UV viewport, when working with large image maps, caused
Modo to perform slowly.

• BUG ID 24733 - Sculpting layout: Changing theMultires palette option from high to low subdivision
levels caused responsiveness issues.

• BUG ID 28257 - Deformers: The Spline Deformer did not work as expected in some scenes.

• BUG ID 29723 - Model layout: Pressing Ctrl+Z to reactivate the Solid Sketch tool, with Snapping
activated and the Snapping Mode set to Vertex and the Constraint Mode set to Background
caused Modo to crash.

• BUG ID 30034 - GL: Undoing the hide selected command (keystroke H), while in Items selection
mode, did not work as expected.

• BUG ID 34400 - UI: Pressing O, to expand the active viewport to fill the entire local frame, did not
work correctly in some viewports.

• BUG ID 37467 - Model layout: PSUBs did not subdivide polygons correctly for some geometry.

• BUG ID 40486 - Model layout: Editing the final point of the Bezier path generator curve left one of
the Bezier node's handles behind.

• BUG ID 40639 - Dynamics: Dynamics Constraints properties for Body A and Body B options did not
work correctly.

• BUG ID 41976 - Shader Tree: Deleting multiple image map instances deleted the original texture
locator.

Release Notes for Modo 11.0v1 | Bug Fixes
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• BUG ID 42901 - Deformers: The Spline Deformer deformations did not pass cleanly to Locators.

• BUG ID 42982 - Deformers: Channels for the Move tool with custom handles were not automatically
selected.

• BUG ID 43220 - GL: Replicated items were not visible in the OpenGL viewport from certain Camera
or Perspective view angles.

• BUG ID 43388 - Preview: Outputs in disabled group masks rendered.

• BUG ID 43640 - UI: The Spline Effector visibility toggle button did not function as expected.

• BUG ID 43679 - Preview: Changing Render Output values restarted Preview.

• BUG ID 43976 - Dynamics: Dynamic Replicators sometimes froze when they hadn't stopped moving.

• BUG ID 44092 - Scripting: Script errors occurred when running lx.eval("item.tag string DESC ?")
with more than 2047 characters.

• BUG ID 44501 - Model layout: The Spline Effector and Bezier Effector tools did not work with 1-
segment source/target.

• BUG ID 44763 - File Output: Canceling Export as tiled EXR to... didn't quit the command
immediately.

• BUG ID 45086 - Render: Using an imported SVG to drive displacement with IC enabled resulted in
the render hanging.

• BUG ID 45637 - Deformers: Some polygons in a Mesh item were collapsed by the Spline Effector.

• BUG ID 45847 - Volumes: VDBVoxel motion blur was oriented incorrectly.

• BUG ID 46046 - Deformers: Bezier node handles appeared incorrectly when ignoretransform
channel was set to True.

• BUG ID 46499 - Windows only: Autosave changed focus back to Modo when working in another
application.

• BUG ID 47548 - Dynamics: Applying a Procedural Shatter to an Active Rigid Body object with an
applied force didn't work as expected.

• BUG ID 48385 - UI: Clicking on a tool from a popover and then clicking in the 3D viewport did not
activate the tool.

• BUG ID 48625 - Render: Vertex Irradiance Caching displayed artifacts.

• BUG ID 49141 - File Input: Alembic particles didn't provide Particle ID information.

• BUG ID 49145 - Deformers: Creating a loop using a Bezier Effector deformed incorrectly and caused
kinks in the mesh.

• BUG ID 49433 - Procedurals: Weights were not propagated to new vertices created by the Polygon
Bevelmesh operation.

• BUG ID 49516 - UI: Lines sometimes appeared under form labels.

• BUG ID 49683 - Model layout: Resolution was lost around the root point using the Tube primitive
with Closed box and By Length options enabled.

Release Notes for Modo 11.0v1 | Bug Fixes
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• BUG ID 49814 - Render: Large material roughness values sometimes created invalid Fresnel
calculations and caused Modo to crash.

• BUG ID 49871 - UI: The UV View window could not be maximized in the Game Tools layout.

• BUG ID 49965 - UV: Modifying vertices in the UV Editor caused Modo to crash.

• BUG ID 50189 - UI: Changing the brush size with the right mouse button caused panels to redraw
with the Mesh Paint tool, including the Mesh Preset window.

• BUG ID 50364 - GL: The Advanced viewport showed visible seams and noise after turning off
environment textures.

• BUG ID 50486 - If a mesh had a deformer affecting it, you could not deselect elements using lasso or
Ctrl/Cmd+paint with your mouse.

• BUG ID 50820 - UI: Headers or dividers in the Color Picker Color tab didn't collapse.

• BUG ID 50970 - File Output: Exporting frozen surface generator particles in Alembic format failed.

• BUG ID 51061 - UI: Adding Utility > Bake Wizard as a new tab in the right pane caused Modo to
crash.

• BUG ID 51179 - Procedurals: Polygon artifacts were created using the UV Transform mesh
operation.

• BUG ID 51228 - UV: The vert.join command sometimes merged discontinuous UV vertices
incorrectly.

• BUG ID 51339 - GL: The 3D viewport did not update when disabling masks containing a
displacement.

• BUG ID 51369 - GL: Loading a specific preset with Replicators turned the viewport yellow and
reported an error.

• BUG ID 51640 - File Output: Autosave and scene close failed with unsaved UDIM images.

• BUG ID 52093 - Deformers: Disabling a Spline Effector and then enabling a Bezier Effector did not
update the scene.

• BUG ID 52225 - Shader Tree: Duplicating an instance did not create a duplicate, it created an
instance of an instance.

• BUG ID 52261 - File Output: Consolidating clips to a tiled EXR function reset the UDIM numbers on
all clip items.

• BUG ID 52337 - Shader Tree: Using Add Layer > Group when either the Light or Environment items
were selected did not create the group under the Render item.

• BUG ID 52456 - Particles: The Spacing Distance for a Curve Particle Generator did not generate a
regular pattern as expected.

• BUG ID 52527 - Render: Black dots (NaNs) appeared in the Render viewport with replicated Catmull-
Clark SubDs.

• BUG ID 52553 - Render: Light sources with negative intensity values were clipped badly into black.
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• BUG ID 52587 - UI: Adding a plug-in to many servers caused a stack overflow in
CompStandardMessageCompose.

• BUG ID 52654 - Procedurals: Setting Size of an axis to 0 for a Cube mesh operation resulted in a
random direction of polygon surfaces.

• BUG ID 52801 - Shader Tree: Right-clicking on aMesh Ops item, to remove it, deleted a previously
selected Material item instead.

• BUG ID 52841 - Procedurals: The Clone mesh operation did not work correctly when the source was
connected.

• BUG ID 52886 - GL: Draw Faded Grid did not work when the Preferences > Input > Units >
Coordinate System > Up Axis option was set to X or Z.

• BUG ID 52891 - Network: Rendering progress did not correctly update in the lower pane of the
Render window, when network rendering by frames with slaves only.

• BUG ID 53088 - GL: Independent drawing did not work in the Default and Advanced viewports.

• BUG ID 53151 - Render: Saving passes as images sometimes saved the wrong alpha when the scene
only had alpha outputs in material masks.

• BUG ID 53182 - GL: The faded grid colors of the axis in the 3D viewport were incorrect when
switching from Advanced to Default.

• BUG ID 53209 - Item List: Creating a Group randomly positioned the folder in the Item List.

• BUG ID 53224 - Schematic: Assembly and Alias vector channels did not show gang edit properties.

• BUG ID 53225 - Network: Render progress was not displayed at the top of the Render window, when
rendering on a network by frames with slaves only.

• BUG ID 53254 - Model layout: Major performance problems occurred when working on specific
groups of polygons in a large complex mesh.

• BUG ID 53283 - Dynamics: Selecting options from the Geometry >Mesh Shatter menu caused
Modo to crash.

• BUG ID 53324 - Procedurals: Applying the Freeze mesh operation to Bezier text left extra vertices.

• BUG ID 53326 - Schematic: Aliases could not be dragged into the Schematic viewport.

• BUG ID 53333 - UV: Using the Transform tools with the Element action center in the UV Editor did
not work as expected.

• BUG ID 53356 - Particles: VDBVoxel items created from particles did not update when the particles
were changed.

• BUG ID 53398 - UI: All selected layers did not update when toggling visibility (eye icon) in the Clips
tab.

• BUG ID 53424 - Model layout: Focus did not work with Morph targets when Deformers were
enabled.

• BUG ID 53446 - UI: Highlighted areas on the Properties panel, during mouse over, sometimes
remained highlighted after moving the mouse away.
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• BUG ID 53460 - Deformers: Selection Operators were added to the bottom of the graph list when
added through the Deformers list.

• BUG ID 53476 - File Output: Two UV sets on a single mesh were not applied correctly to an exported
Unity mesh.

• BUG ID 53488 - Render layout:  Changing the Target Color in the Render Window Image
Processing tab reverted the color back to white.

• BUG ID 53498 - Mac OS X only: Export Selected Layers caused Modo to crash.

• BUG ID 53503 - Scripting: Disconnecting graph connections using the bitshift-operator (<<) caused
an error.

• BUG ID 53542 - Presets: The Scatter Clone tool sometimes crashed when selecting another Preset.

• BUG ID 53565 - Procedurals: Memory was not released after deleting a VDBvoxel item used by a
Merge Meshes operation.

• BUG ID 53588 - UI: Overwriting 3D viewport presets caused Modo to crash.

• BUG ID 53603 - Item List: item.duplicate default settings changed based on the last time it was
called.

• BUG ID 53624 - Network Rendering: Image processing was not possible with offloaded rendering on
a network render, using slaves only.

• BUG ID 53625 - Paint: The Fill and Smudge buttons didn't appear as active (orange) when clicked.

• BUG ID 53713 - Scripting: Several vertex and polygon properties returned values from the wrong
components.

• BUG ID 53716 - GL: Onion Skinning did not work in the Advanced viewport.

• BUG ID 53737 - Volumes: Reverting a scene, after running the scene containing a VDBvoxel item in
the Preview, caused Modo to crash.

• BUG ID 53741 - Scripting: Querying edge selection resulted in a MeshEdges object had no attribute _
mesherror.

• BUG ID 53742 - UI: Changing the System > Preferences > Input > Drop Mappings option to
Viewport Override did not update the mapping list.

• BUG ID 53743 - UI: Game input mapping shortcut changes were not saved when switching presets.

• BUG ID 53748 - Model: Using the Apply Morph tool to transfer the morph values from a relative to
an absolute morph created unexpected results.

• BUG ID 53766 - Volumes: VDBVoxel cache glitches occurred in the 3D viewport and Render view.

• BUG ID 53767 Render: Increasing the value of Spread Angle for a Directional Light caused specular
noise.

• BUG ID 53779 - Scripting: Deselecting edges after running a script that selected them was not
possible.

• BUG ID 53780 - Model: 2D overlapping edge selections often failed.

• BUG ID 53781 - File Input: Image viewer displayed tiled EXR aspect ratio incorrectly.
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• BUG ID 53790 - Render: Scaling down a single mesh light axis made the light brighter.

• BUG ID 53792 - Network Rendering: Aborting a network render, using slaves only, caused incorrect
functionality and occasionally resulted in Modo crashing.

• BUG ID 53805 - Model layout: Collapsing edges, with edge weighting assigned to them, incorrectly
applied weighting to new vertices.

• BUG ID 53806 - Model layout: Edge weighting didn't propagate correctly when applying the Edge
Bevel and Polygon Bevel tools.

• BUG ID 53816 - Animation: Deleting an item in a scene, with an active Command Region, caused
Modo to crash.

• BUG ID 53817 GL: Image sequences used as a GL Background performed slowly.

• BUG ID 53839 - Replicators: The viewport performance, with a scene containing a Replicator using
multiple prototypes, was slow in Modo.

• BUG ID 53844 - SDK: It was not possible to put geometry into setup mode when using a
CharacterBox kit script.

• BUG ID 53860 - Particles: Replicating items along a curve using the Curve Particle Generator created
alignment issues.

• BUG ID 53868 - Model layout: The polygon.make command did not work on Subdivs (1 or 2 FACE
Polygons).

• BUG ID 53893 - Model layout: Mirror merged vertices with hidden geometry.

• BUG ID 53897 - File Output: Exporting Selected Layers did not export Library shaders.

• BUG ID 53910 - GL: Hit testing on curves with transformed parent items was incorrect.

• BUG ID 53914 - UV: UV background images took significantly longer to display than in Modo 10.2.

• BUG ID 53925 - Render: Modo crashed when trying to render with a corrupt frame buffer file on
disk.

• BUG ID 53929 - GL: The Environment > Outdoor > Outdoor Spherical 02 preset did not display
after switching GL Background to Environment.

• BUG ID 53939 - UI: When a Locator with children was selected, clicking on another item's Delete
button presented a warning to delete the Locator.

• BUG ID 53954 - UI: Area Lights allowed setting negative size values when using the tool handles but
did not allow negative values set in the Properties pane.

• BUG ID 53955 - UI: With the Preferences > Display > Tool Handles > Draw Style option set to
Advanced and Edit > Show Dimensions enabled, incorrect values were displayed in the viewport.

• BUG ID 53967 - Shader Tree: Editing multiple selected groups of textures in the Shader Tree did not
work as expected.

• BUG ID 53971 - Model layout: The Symmetrize mesh operation did not work with a Morph Map.

• BUG ID 53993 - Preview: Preview did not always update when shaders were moved in the Shader
Tree.
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• BUG ID 54007 - UI: Channel state randomly changed to edit mode.

• BUG ID 54012 - UI: Reopening the Edge Selection Set panel, after searching for a property that did
not exist, caused Modo to crash.

• BUG ID 54020 - Fusion: Modo performed slowly for a scene containing many MeshFusion items and
resulted in unnecessary updates.

• BUG ID 54034 - Model layout: The OpenSubdiv item caused Modo to crash when closing the scene.

• BUG ID 54037 - Model layout: Undoing an Element Falloff caused Modo to crash.

• BUG ID 54041 - UI: Read-only commands caused panels to size incorrectly.

• BUG ID 54046 - Windows only: Using Bake from Object to Render Outputs sometimes resulted in
bad buckets.

• BUG ID 54046 - Render: Optimization for shadow rays caused artifacts in object-to-object baking.

• BUG ID 54054 - Color: Color Picker RGB (HDR) channels capped at 1.125 with Global Options >
Numeric CS set to the default sRGB colorspace.

• BUG ID 54056 - UI: The default Preference setting for the FBX Export File Format was not set to
Use Latest.

• BUG ID 54058 - Model layout: MeshFusion randomly failed to produce a mesh.

• BUG ID 54065 - Dynamics: The Dynamic Replicator Force options influenced Soft Body items.

• BUG ID 54067 - Render: Mesh smoothing caused the deferred shading samples to merge incorrectly
by the shading rate and caused longer render times.

• BUG ID 54077 - UI: The Opacity channel for the Morphed Mesh drawing option, Drawing Style to
Cage, was not limited to a 0 -1 range.

• BUG ID 54085 - UI: Changing System > Preferences > Date > Preset Markup Definitions types
sometimes caused Modo to crash.

• BUG ID 54090 - Shader Tree: Occlusion rays were fired regardless of material mask and caused
unnecessary calculations.

• BUG ID 54091 - Model layout: A MeshFusion scene produced an incorrect mesh after switching to
the output mode Airtight Final with Parts.

• BUG ID 54092 - Model layout: Applying a geometry Freeze on a mesh that had a displacement map
and Deformer caused Modo to crash.

• BUG ID 54093 - Procedurals: Deformers could not be disabled until their Effector was deselected.

• BUG ID 54096 - Model layout: Clone tools used with curves were not working as expected.

• BUG ID 54110 - Model layout: Align Work Plane to Selection did not work correctly with polygons
parallel to world axis.

• BUG ID 54114 - Deformers: Setting the Spline Deformer Number option to 2 caused Modo to crash.

• BUG ID 54120 - UV: Selecting the UV island by double-clicking in Polygon selection mode, when the
mesh was deformed or keyed was not possible.

• BUG ID 54132 - Preview: Volumetrics was reset in Preview after an Autosave.
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• BUG ID 54133 - Shader Tree: Using the drag-and-drop action from the Shader Tree onto a mesh
caused Modo to crash.

• BUG ID 54140 - GL: When a viewport preset loaded from the config that was set to use the
Advanced viewport, the Advanced viewport was disabled.

• BUG ID 54143 - Scripting: Firing viewport.infoSub caused Modo to crash.

• BUG ID 54146 - Scripting: Adding a vertex in a script was not working.

• BUG ID 54148 - GL: Invisible inactive items caused the viewport navigation to not work as expected.

• BUG ID 54150 - Scripting: Querying view3dservice mouse.hitPos did not work unless the element
under the mouse was on a selected item.

• BUG ID 54165 - Scripting: Recorded macros and Python scripts did not allow you to use several core
tools.

• BUG ID 54167 - Network Render: A network rendering function crashed during a bake border
expansion.

• BUG ID 54172 - Item List: Using the backspace key after selecting an item produced a Schematic
node removal error.

• BUG ID 54174 - UI: Remapping the mouse input preset to Maya or (Alt-LMB-MMB zoom) caused the
panel not to set the location/pinning state.

• BUG ID 54184 - Model layout: Setting the angle to 180 degrees on the Arc tool caused the geometry
to disappear.

• BUG ID 54199 - Dynamics: Dragging a Softbody into another scene caused Modo to crash.

• BUG ID 54206 - Model layout: The Vertex Map > Apply Morph option did not work as expected.

• BUG ID 54208 - Dynamics: The Procedural Shatter did not connect to the geometry and the solver
was missing.

• BUG ID 54214 - Render layout: Vertex Illumination Baking was broken for transformed items.

• BUG ID 54219 - UI: Renaming textures caused Modo to crash if a render item channel toggle was
displayed in the UI.

• BUG ID 54229 - Dynamics: Simulating at the current time with a specific scene caused Modo to
crash.

• BUG ID 54230 - Model layout: Drawing a tube in a mesh with procedural operators caused Modo to
crash.

• BUG ID 54240 - Item List: Removing tags did not mark the scene as changed and changes were lost
when closing the scene in Modo.

• BUG ID 54249 - Render layout: UV seams caused baking to break.

• BUG ID 54263 - Render layout: Portals did not work as expected.

• BUG ID 54274 - Procedurals: Curve Extrude polygons flipped when the sweep path was rotated.

• BUG ID 54276 - Render layout: Moving the render camera's target sometimes caused Modo to crash.
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• BUG ID 54300 - Shader Tree: Copying multiple texture layers was not possible and the colors of a
pasted texture layer were not transferred.

• BUG ID 54301 - Mesh Types: Changing from an instance to a mesh did not respect multiple
selections.

• BUG ID 54345 - File Input: Reloading an auto-saved scene, when references were not auto-saved
caused Modo to crash.

• BUG ID 54353 - UV: Edge Bevel incorrectly created UVs in an empty UV map.

• BUG ID 54362 - UI: A corrupted customized config file was deleted rather than renamed.

• BUG ID 54379 - Preview: Preview did not output black values in the Alpha output when rays missed
the surface in Bake mode.

• BUG ID 54386 - GL: Locking the Work Plane did not make it visible when the visibility was set to
active.

• BUG ID 54393 - UV: Setting the polygon type to Subdivs with UV Distortion enabled, caused Modo
to crash.

• BUG ID 54413 - File Input: Importing multiple SolidWorks files sometimes caused Modo to crash.

• BUG ID 54509 - Volumes: VDBVoxel did not load assets compressed with Blosc.

• BUG ID 54516 - Render layout: Render curves rendered black.

• BUG ID 54552 - File Output: Game Tools > Export failed when the material had an image in it.

• BUG ID 54556 - Deformers: Handles appeared in the incorrect location on deformed items.

• BUG ID 54566 - UI: Work Plane spelling was not consistent.

• BUG ID 54579 - Fusion: MeshFusion items were invisible when the 3D Viewport Properties >
Visibility > Show Locators option was disabled.

• BUG ID 54631 - Particles: Particle Look At Modifier Apply 0% incorrectly modified the incoming
particles.

• BUG ID 54639 - Performance: vertMap.applyMorph caused unnecessary procedural mesh
evaluation when selection changed.

• BUG ID 54647 - Model layout: Applying Edge Fill Quad and a fill with a grid pattern option produced
a 2 polys unsubdivided in a 3 x 1 polygon selection.

• BUG ID 54676 - Model layout: Reusing Select > Use Selection Set caused Modo to crash.

• BUG ID 54816 - Windows only: The DirectShow API framework failed to load an audio file and
caused Modo to crash.

• BUG ID 54825 - GL: PSub was corrupted when changing the subdivision level.

• BUG ID 54847 - Particles: The Curve Particle Generator incorrectly spaced particles.

• BUG ID 54860 - File Output: Exporting a mesh item parented to an instance item to .fbx caused
Modo to crash.

• BUG ID 54877 - File Input: The MDD reader did not close files and the handle count increased as you
moved around in the Timeline.
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• BUG ID 54905 - Particles: The Point Count channel disappeared from the properties of the Curve
Particle Generator.

• BUG ID 54906 - Replicators: Replicator and Curve Particle Generator using bad geometry caused
Modo to crash.

• BUG ID 55009 - Volumes: Volume rendering with VDBVoxel items had clipping issues.

• BUG ID 55019 - Fusion: Moving meshes that are part of a MeshFusion item sometimes caused Modo
to crash.

• BUG ID 55123 - Scripting: Using a script to bake items in a scene sometimes caused Modo to crash.

Known Issues and Workarounds
This section covers known issues and gives workarounds for them, where appropriate.

Advanced Viewport

• BUG ID 50810 - Anisotropic texture filtering is lower quality than in the Default viewport.

• BUG ID 49598 - Spurious diagonal lines of bad pixels may appear in the Advanced viewport with
some AMD cards.

• BUG ID 46995 - Ambient Occlusion display in the Advanced viewport is affected by selected item
wireframes.

You can disable Show Selection in the Visibility options or disable wireframe drawing on the active
mesh layers.

Animation

• BUG ID 53661 - Selecting actions does not always select the correct one. This is caused by copying
actions.

As a workaround, manually edit the tags on the broken actions by selecting them in the Groups tab,
then save and reload the scene.

Assemblies

• BUG ID 36452 - Assemblies exported from the Item List context menu result in poor visual layout of
nodes on import.

As a workaround, you can save assemblies from the Schematic viewport.
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Audio

• BUG ID 52242 - Windows only: The .au format doesn't load on Windows 10, due to the lack of
DirectShow support for the format.

As a workaround, convert the audio file to a different format, such as .wav. This bug will not be
fixed.

Baking

• BUG ID 50671 - Baking displacement maps can cause UV seams to be visible, and the baked
displacement map to show quilting effects and other render artifacts.

• BUG ID 49437 - The Bake Channel Swizzling option can’t bake to texture alpha.

Color Management

• BUG ID 49244 - Windows only: With Perform Color Correction on, setting a default scene to a
scene with a mesh that has a position channel crashes Modo at launch.

As a workaround, use System > Reset Preferences to reset to defaults or move/remove the default
scene.

Default Viewport

• RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any
unsupported texture effect on an image map is drawn as diffuse color when the layer is selected in
the Shader Tree.

File and Image I/O

• BUG ID 50198 - Alembic scenes don't export some surface items, including static meshes and
procedural shatter items.

• BUG ID 49728 - Exporting selected layers (from the Item List context menu) to .fbx doesn't export
instances, unless the original mesh is also exported.

To resolve this, set the .fbx preference to Export Selection and use Export As….

• BUG ID 47036 - Color management in .svg images is not currently supported. This is a side-effect of
a bug fix where the largest allowable image size (64k x 64k) was always used when color correction
was enabled.
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• BUG ID 46962 - Rendering .svg images used as stencil maps for displacement or for layer masking
can be very slow.

Fur

• BUG ID 35731 - Fur length textures can’t be edited with the Stretch tool.

Use different fur length drivers, such as hair guides or vector vertex maps.

General

• BUG ID 49514 - Mac OS X only: Runningmodo_cl before running the UI Modo application breaks
code signing.

As a workaround, start the UI version of Modo once, before runningmodo_cl on any system where
you later intend to use the UI version.

GL

• Windows only: Using Raptr can cause GL driver crashes in Modo.

Input Devices

• BUG ID 51741 - Mac OS X only: Modo sometimes becomes unresponsive when using the
combination of a click-drag in a tree view (for example, when toggling the visibility of two successive
items in the Shader Tree), followed immediately by a two-finger scroll gesture on some devices,
including laptop trackpads and the Magic Mouse.

As a workaround, change to a 3-button mouse (recommended to fully access all of Modo's features).

• BUG ID 35856 - Linux only: Plugging in a Wacom tablet while Modo is running can cause undesired
movement. This cannot be fixed, due to a limitation of the hardware driver.

To avoid this, plug in the tablet before application startup or restart.

Item List

• BUG ID 53209 - Group creation (Ctrl+G) places the new group folder at a random position in the
Item List, if the items are not selected in a top down sequence.

As a workaround, select the items being grouped from top to bottom in the Item List before
grouping (Ctrl+G).
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Modeling

• BUG ID 32728 - Zooming out with a Space Navigator alters the Work Plane position.

Network Rendering

• BUG ID 48325 - Scenes with image sequences rendered with Full Frames use the wrong image
sequence number on slave machines.

As a workaround, use File > Consolidate Scene, then render the scene using a shared network
folder (Preferences option under Rendering > Network Rendering).

• BUG ID 36986 - Slaves render hidden meshes. Since mesh visibility state is not stored in the scene,
when that scene is transferred to the slaves, the state is lost. However, the master respects the
hidden state.

As a workaround, If the intent is to avoid rendering, use the item or render visibility instead (eye
icon in the Item List, or set Render to No on the mesh item properites). This is not a bug and won’t
be fixed.

• BUG ID 30318 - Network Rendering doesn’t support Realflow particles.

• BUG ID 25636 - Frame passes are not supported.

Nodal Shading

• BUG ID 50642 - Nodal shading does not support UDIMs.

Painting/Sculpting

• BUG ID 41682 - Textures are not always updating in Preview/Render when painting on an image
map.

You can save and reload the image to force the update.

Particles

• BUG ID 44551 - Surface Particle Generators may not update with changes to a Density Gradient
Input set to Slope.

As a workaround, choose Distance to Locator or any other setting from the Density Gradient
Input dropdown, then change it back to Slope.
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• BUG ID 34925 - Re-opening scenes saved with large particle caches can cause problems.

To avoid such issues, delete the cache before closing Modo, or export the particles to .csv cache
files or Realflow .bin files. You can do this by attaching one of those nodes to the Particle Simulation
item in the Schematic viewport, and clicking Cache Simulation.

Preview

• If a high poly mesh is not visible, the Preview baking output will be incorrect.

Reset Preview to fix the baking.

Procedurals

• BUG ID 52149 - Curve Extrude mesh operation: The Path Segment Generator's Align to Normal
option doesn't work when using a Bezier with zero-length tangents.

As a workaround, rotate the polygons to point toward the +Z before extruding or make sure there
are no zero-length tangents.

• BUG ID 49767 - Scenes, which contain a UV constraint modifier driving texture properties, may fail
to load after saving, due to a modifier dependency loop.

• BUG ID 46512 - When rigged, Rock items and other procedurals do not display correctly in GL. This
is a limitation of the feature and will not be fixed.

You can use Preview or RayGL to visualize the variations from rigging.

Projections

• BUG ID 49473 - Projections are incorrect if the projecting camera is set to Vertical film fit mode and
the width is less than the height.

• BUG ID 43771 - Camera projections from non-render cameras show distortion in GL and baking.

To avoid this, make sure that the projection camera has a film width-to-height ratio that matches
the main render camera.

References

• BUG ID 44492 - If a scene that already contains references is referenced, the shading of the original
references may not persist.

As a workaround, limit scenes with shading to one level of reference.
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• BUG ID 41119 - Reloading a reference after replacing it with the same file can cause Modo to crash.

Rendering

• BUG ID 53411 - Mesh lights or any direct light too close to a surface can produce fireflies (hot pixels)
in some cases.

As a workaround, use aMaximum Radiance higher than 1 W/srm2 to reduce the bias.

• BUG ID 53184 - Value presets created for material Subsurface Scattering samples in Modo 10.1 or
earlier now show on the render item instead.

• BUG ID 52730 - The Vertex Illumination Bake command doesn't work as expected, when the mesh
has transform channels.

As a workaround, freeze the transforms in the mesh properties.

• BUG ID 52011 - Tangent Basis handles Mirror UVs incorrectly.

As a workaround, apply Mikk or any other tangent space basis to the mesh before baking.

• BUG ID 46468 - Additional (masked) alpha outputs are not saved when rendering animations.

Since other render outputs do work, a remapped depth output with a very high maximum depth
setting functions similarly to an alpha output.

Rigging

• BUG ID 27244 - Duplicating joints in a bound mesh retains influences from the original joint chain.

Scripting

• BUG ID 53458 - Right-clicking or running a script in the Script Editor can lock up input to Modo.

As a workaround, click in the top window of the Script Editor, use the main menus, or change to
another application, then switch back to Modo.

Shader Tree

• BUG ID 37858 - In the Shader Tree, choosing a group from Add Layer > Image Map > (use clip
browser) fails.

To work around this issue, in the Clip Browser, choose a single image instead of the group, and
then change to the image group using the Texture Layer's Properties tab.
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• BUG ID 30947 - Layer masking displacement does not work unless you drag and drop the masking
layer onto the displacement layer.

Unreal and Unity Materials

• BUG ID 50701 - Unreal material Ambient Occlusion does not bake correctly in Modo.

• BUG ID 50700 - There is no way to visualize the Unreal SubSurface Color effect in Modo.

• BUG ID 50451 - On some graphics cards, Unity material may cause flickering in the Advanced
viewport when used with bump maps and shadows.

UI

• BUG ID 44496 - Mac OS X only: Disabling Affect System Color Dialog in Preferences > Rendering
> Color Management, and using the system color picker causes colors to darken with each use of
the color picker.

This is due to an OS X issue, which requires the color profile in both the monitor settings and color
picker to be set to sRGB IEC61966-2.1.

• BUG ID 44896 - Dragging and dropping an image from disk into the Clips list doesn’t work.

If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it above or below
other images in the list.

• BUG ID 43162 (Windows only) -Setting a custom text size affects Modo's text drawing.

As a workaround, go to the compatibility settings by right-clicking the Modo shortcut or executable,
and turn off font-scaling for the application.

Volumes

• VDBVoxel items support OpenVDB 3.0 files or earlier and don't properly load those encoded with
Blosc.

Developer Notes
Here are the changes relevant to developers.

Bug Fixes and Enhancements
• SDK: It was not possible to get a CLxUser_SchematicNode() interface from a Schematic item node.
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• SDK: ILxSchematicNodeConnection has been replaced with ILxSchematicNodeChannel in the
Schematic SDK.
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